Browse Source

Updated to xtext and xtend 2.14.0

Casper Thule 2 years ago
parent
commit
af6253cb01

+ 1 - 1
DSL_SemanticAdaptation/be.uantwerpen.ansymo.semanticadaptation.tests/META-INF/MANIFEST.MF

@@ -9,7 +9,7 @@ Require-Bundle: be.uantwerpen.ansymo.semanticadaptation,
  org.junit;bundle-version="4.7.0",
  org.eclipse.xtext.junit4,
  org.eclipse.xtext.xbase.junit,
- org.eclipse.xtext.xbase.lib,
+ org.eclipse.xtext.xbase.lib;bundle-version="2.14.0",
  org.eclipse.jdt.core,
  org.eclipse.xtext.testing,
  org.eclipse.xtext.xbase.testing,

+ 1 - 1
DSL_SemanticAdaptation/be.uantwerpen.ansymo.semanticadaptation.ui/META-INF/MANIFEST.MF

@@ -17,7 +17,7 @@ Require-Bundle: be.uantwerpen.ansymo.semanticadaptation,
  org.eclipse.compare,
  org.eclipse.xtext.builder,
  org.eclipse.xtend.lib;resolution:=optional,
- org.eclipse.xtext.xbase.lib,
+ org.eclipse.xtext.xbase.lib;bundle-version="2.14.0",
  org.apache.commons.io
 Import-Package: org.apache.log4j
 Bundle-RequiredExecutionEnvironment: JavaSE-1.8

+ 24 - 0
DSL_SemanticAdaptation/be.uantwerpen.ansymo.semanticadaptation.ui/plugin.xml_gen

@@ -204,6 +204,15 @@
 			</activeWhen>
 		</handler>
 	</extension>
+	<extension point="org.eclipse.core.contenttype.contentTypes">
+		<content-type
+			base-type="org.eclipse.core.runtime.text"
+			file-extensions="sa"
+			id="be.uantwerpen.ansymo.semanticadaptation.SemanticAdaptation.contenttype"
+			name="SemanticAdaptation File"
+			priority="normal">
+		</content-type>
+	</extension>
 	<!-- adding resource factories -->
 	<extension
 		point="org.eclipse.emf.ecore.extension_parser">
@@ -240,6 +249,15 @@
 		<super type="org.eclipse.xtext.ui.check.expensive"/>
 		<persistent value="true"/>
 	</extension>
+	<extension point="org.eclipse.ui.preferencePages">
+		<page
+			category="be.uantwerpen.ansymo.semanticadaptation.SemanticAdaptation"
+			class="be.uantwerpen.ansymo.semanticadaptation.ui.SemanticAdaptationExecutableExtensionFactory:org.eclipse.xtext.ui.validation.ValidatorPreferencePage"
+			id="be.uantwerpen.ansymo.semanticadaptation.SemanticAdaptation.validator.preferencePage"
+			name="Errors/Warnings">
+			<keywordReference id="be.uantwerpen.ansymo.semanticadaptation.ui.keyword_SemanticAdaptation"/>
+		</page>
+	</extension>
 	<extension point="org.eclipse.xtext.builder.participant">
 		<participant
 			class="be.uantwerpen.ansymo.semanticadaptation.ui.SemanticAdaptationExecutableExtensionFactory:org.eclipse.xtext.builder.IXtextBuilderParticipant"
@@ -388,12 +406,18 @@
 			class="be.uantwerpen.ansymo.semanticadaptation.ui.SemanticAdaptationExecutableExtensionFactory:org.eclipse.xtext.ui.compare.InjectableViewerCreator"
 			extensions="sa">
 		</viewer>
+		<contentTypeBinding
+			contentTypeId="be.uantwerpen.ansymo.semanticadaptation.SemanticAdaptation.contenttype"
+			contentViewerId="be.uantwerpen.ansymo.semanticadaptation.SemanticAdaptation.compare.contentViewers" />
 	</extension>
 	<extension point="org.eclipse.compare.contentMergeViewers">
 		<viewer id="be.uantwerpen.ansymo.semanticadaptation.SemanticAdaptation.compare.contentMergeViewers"
 			class="be.uantwerpen.ansymo.semanticadaptation.ui.SemanticAdaptationExecutableExtensionFactory:org.eclipse.xtext.ui.compare.InjectableViewerCreator"
 			extensions="sa" label="SemanticAdaptation Compare">
 		</viewer>
+		<contentTypeBinding
+			contentTypeId="be.uantwerpen.ansymo.semanticadaptation.SemanticAdaptation.contenttype"
+			contentMergeViewerId="be.uantwerpen.ansymo.semanticadaptation.SemanticAdaptation.compare.contentMergeViewers" />
 	</extension>
 	<extension point="org.eclipse.ui.editors.documentProviders">
 		<provider id="be.uantwerpen.ansymo.semanticadaptation.SemanticAdaptation.editors.documentProviders"

+ 2 - 2
DSL_SemanticAdaptation/be.uantwerpen.ansymo.semanticadaptation/META-INF/MANIFEST.MF

@@ -9,10 +9,10 @@ Require-Bundle: org.eclipse.xtext,
  org.eclipse.xtext.xbase,
  org.eclipse.equinox.common;bundle-version="3.5.0",
  org.eclipse.emf.ecore,
- org.eclipse.xtext.xbase.lib,
+ org.eclipse.xtext.xbase.lib;bundle-version="2.14.0",
  org.antlr.runtime,
  org.eclipse.xtext.util,
- org.eclipse.xtend.lib,
+ org.eclipse.xtend.lib;bundle-version="2.14.0",
  org.eclipse.emf.common,
  org.eclipse.core.runtime;bundle-version="3.12.0"
 Bundle-RequiredExecutionEnvironment: JavaSE-1.8

+ 1 - 1
DSL_SemanticAdaptation/be.uantwerpen.ansymo.semanticadaptation/pom.xml

@@ -116,7 +116,7 @@
 					<dependency>
 						<groupId>org.eclipse.emf</groupId>
 						<artifactId>org.eclipse.emf.mwe2.launch</artifactId>
-						<version>2.9.0.201605261059</version>
+						<version>2.9.1.201705291010</version>
 					</dependency>
 
 

+ 1 - 1
DSL_SemanticAdaptation/be.uantwerpen.ansymo.semanticadaptation/src/be/uantwerpen/ansymo/semanticadaptation/scoping/SemanticAdaptationScopeProvider.xtend

@@ -338,7 +338,7 @@ class SemanticAdaptationScopeProvider extends AbstractDeclarativeScopeProvider
 	
 	private IScopeWrapper scopeWrapper;
 	
-	def public void setWrapper(IScopeWrapper wrapper) {
+	override setWrapper(IScopeWrapper wrapper) {
 		this.scopeWrapper = wrapper;
 	}
 

+ 1 - 1
DSL_SemanticAdaptation/pom.xml

@@ -33,7 +33,7 @@
 	<properties>
 		
 		<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
-		<xtext.version>2.11.0</xtext.version>
+		<xtext.version>2.14.0</xtext.version>
 
 		<main.basedir>${project.basedir}</main.basedir>
 		<tycho.version>1.0.0</tycho.version>